Sommare valori che rispettano condizioni con SOMMA.SE su Excel

Sommare valori che rispettano condizioni con SOMMA.SE su Excel

Sommare valori che rispettano condizioni con SOMMA.SE su Excel: La funzione SOMMA.SE permette di sommare solamente i valori che rispettano determinate condizioni preimpostate da noi.

Possiamo utilizzare questa funzione ad esempio per sommare tutti i valori maggiori di 100, oppure ancora per sommare tutti i valori già pagati, o tutti i valori di una stessa categoria.

La sintassi della funzione SOMMA.SE è:

  • =SOMMA.SE(VALORI_DA_CONFRONTARE;METODO_DI_CONFRONTO; VALORI_DA_SOMMARE)
  • =SOMMA.SE(VALORI_DA_SOMMARE_E_CONFRONTARE;METODO_DI_CONFRONTO)

Sono 2 sintassi, la prima da utilizzare quando i valori da confrontare non fanno parte dei valori da sommare (quindi ad esempio per controllare la presenza di una parola specifica.

La seconda invece la utilizziamo quando vogliamo sommare dei valori e applicare la condizione direttamente sui valori stessi.

Vediamo 2 esempi pratici

Sommare valori che rispettano condizioni con SOMMA.SE su Excel

AB
1Hard Disk120
2Scheda Grafica400
3RAM80
4RAM80
5Processore300

In questa tabella abbiamo diversi componenti di un PC con i relativi costi.

Se ad esempio volessimo avere la somma solo delle RAM andremo a scrivere:

=SOMMA.SE(A1:A5;”RAM”;B1:B5)

In questo modo andiamo a controllare tutte le celle da A1 fino ad A5 alla ricerca della parola RAM, quando viene trovata viene sommato il valore corrispondente.

In questo caso le celle sono vicine, ma è possibile farlo anche con celle non adiacenti, l’importante è che il numero di celle del primo gruppo sia uguale al secondo gruppo.

Quindi se scrivo A1:A10 (10 celle) necessariamente il secondo gruppo dovrà avere 10 celle, quindi potrà essere B1:B10, F1:F10, F11:F20 ecc.

È possibile contare anche solo le celle che non hanno la parola RAM, in questo caso dovremo usare il simbolo DIVERSO che su Excel si scrive <>.

Quindi per avere la somma di tutti i costi, escluso i costi della RAM scriveremo:

=SOMMA.SE(A1:A5;”<>RAM”;B1:B5)

Vediamo ora il secondo caso, abbiamo sempre gli stessi valori, ma in questo caso non ci interessa avere il costo di tutte le ram, ma vogliamo avere la somma di tutti i costi superiori a 100.

Andremo a scrivere:

=SOMMA.SE(B1:B5;”>100″)

Non includiamo nella funziona le celle con le etichette, perchè non sono importanti.

Confrontiamo solo i valori numerici, e quando sono superiori a 100 li sommiamo.

Si può fare la stessa cosa con i valori inferiori a 100:

=SOMMA.SE(B1:B5;”<100″)

Oppure possiamo sommare solo i valori uguali a 100:

=SOMMA.SE(B1:B5;”=100″)

Nel seguente video è presente un tutorial completo sull’utilizzo della funzione SOMMA.SE

Claudio Masci

Sono innanzitutto un appassionato di informatica e tecnologia in generale. Lavoro in ambito informatico da circa 16 anni, spaziando in diversi campi, andando dalla programmazione web, allo sviluppo di software, dalla grafica alla modellazione 3d ed al video editing, ho sempre voluto approfondire ogni aspetto e questo mi ha permesso di lavorare in diversi ambiti informatici.

Rispondi